PDFlib 10 Beta and Block Plugin 6 Beta

PDFlib 10 Beta Downloads

The PDFlib 10 Beta download packages contain combined binaries for PDFlib, PDFlib+PDI, and PDFlib Personalization Server (PPS).
PDFlib, PDFlib+PDI, and PPS can be evaluated without a license, but display a demo stamp across all generated pages.

PDFlib / PDFlib+PDI / PDFlib Personalization Server (PPS) 10.0.0 Beta 1 (released 10/2021)

Platform Package for use with

Windows - see system requirements

Windows Server x86 and Windows 8/10/11 x86

C, C++

Java Perl PHP Python Ruby
Windows Server x64 and Windows 8/10/11 x64 C, C++ Java Perl PHP Python Ruby
macOS - see system requirements
Universal binary (x64/ARM64) for macOS 10.9 and above C, C++, Objective-C Java Perl PHP Python Ruby
.NET - see system requirements
Universal package for Windows x86, Windows x64, Linux x64, Alpine Linux x64 (musl), macOS x64 all languages supported in .NET
Linux - see system requirements
Linux x64

C, C++

Java Perl PHP Python Ruby

The final PDFlib 10 release will be supported on the same platforms as PDFlib 9.3.1.

Supported versions of language bindings:

  •    PHP 7.4, 8.0 and 8.1
  •    Perl 5.28, 5.30, 5.32 and 5.34
  •    Python 3.3 and newer
  •    Ruby 2.6, 2.7 and 3.0

PDFlib Block Plugin 6 Beta

The PDFlib Block Plugin is part of the PDFlib Personalization Server (PPS). It cannot be licensed separately, but customers with a PPS license can distribute it to their end users.

Downloads
Windows:
Acrobat X/XI
Acrobat Standard and Pro 2017/2020
Acrobat Pro DC (32-bit)
PDFlib Block Plugin 6.0 Beta 1 English, German, Japanese
Windows:
Acrobat Pro DC (64-bit)
PDFlib Block Plugin 6.0 Beta 1 English, German, Japanese

macOS:
Acrobat Standard and Pro 2017/2020 (Intel)
Acrobat DC (universal binary for Intel and M1)

PDFlib Block Plugin 6.0 Beta 1 English, German, Japanese

The PDFlib Block Plugin works with PDFlib Personalization Server (PPS) 10.0.0 Beta 1 or above. Older versions of the PDFlib Block Plugin must be removed before installing this version.