AIX-Binaries für iSeries

Einsatz von AIX-Binaries für IBM i5/iSeries mit PASE

Die Produkte der PDFlib GmbH sind für IBM i5-Systeme verfügbar. Je nach Sprachbindung stehen AIX-Binärprogramme für die Verwendung mit PASE oder interne i5-Binärprogramme zur Verfügung.

Verwendung von Produkten der PDFlib GmbH auf IBM i5 mit Java oder PHP

In manchen Fällen ist IBMs Portable Application Solutions Environment (PASE for i) erforderlich, eine »integrierte Runtime-Umgebung zur Portierung ausgewählter Anwendungen von AIX-Systemen«. PASE ist keine Emulation, sondern nutzt den Prozessor direkt. Deshalb hat PASE auch keine nachteilige Auswirkung auf die Performance. PASE verursacht keine zusätzlichen Kosten, und Anwender müssen sich auch nicht in die AIX-Systemverwaltung einarbeiten, da PASE voll in i5/OS integriert ist. Weitere Informationen zu PASE finden Sie auf der IBM-Website. Auch IBM hat einige Pakete auf PASE umgestellt, vor allem IT4J Java VM.

PASE und AIX-Binärprogramme von Produkten der PDFlib GmbH sind für den Einsatz auf IBM i5 in folgenden Fällen erforderlich:

  • Um PDFlib, TET oder PLOP/PLOP DS mit Java auf i5 zu verwenden, ist IT4J Java VM (32-Bit oder 64-Bit) erforderlich. Abhängig von der installierten Java VM (für weitere Informationen siehe hier), benötigen Sie die Java-Bibliothek, die in den 32-Bit- oder 64-Bit-Varianten der AIX-Pakete von PDFlib, TET oder PLOP/PLOP DS enthalten ist.
  • Einsatz von PDFlib, TET oder PLOP/PLOP DS in PHP mit Zend Server für IBM i. Weitere Informationen, wie Sie unsere Produkte mit PHP auf i5 nutzen können, finden Sie in unserem Dokument PDFlib in PHP HowTo.

Die erforderlichen Produkt-Binaries sind nicht im i5-Paket enthalten, sondern müssen dem entsprechenden AIX-Paket entnommen werden. Obwohl Sie die AIX-Produktpakete in den oben beschriebenen Situationen herunterladen müssen, müssen Sie IBM i5 als Zielplattform angeben, wenn Sie Lizenzschlüssel für AIX-Binärprogramme auf einem i5-System bestellen. Binärprogramme von Produkten der PDFlib GmbH für AIX akzeptieren i5-Lizenzschlüssel, wenn sie mit PASE auf i5/OS ausgeführt werden.

Verwendung von Produkten der PDFlib GmbH auf IBM i5 mit C/C++ oder RPG

Die Produkte der PDFlib GmbH unterstützen native C-, C++- und RPG-Entwicklung auf IBM i auf folgende Arten:

Für PLOP/PLOP DS steht keine native Bibliothek für ILE-C, C++ und RPG zur Verfügung.

Verwendung von Kommandozeilen-Tools der Produkte der PDFlib GmbH auf IBM i5

Kommandozeilen-Tools der folgenden Produkte der PDFlib GmbH können mit PASE auf IBM i5 genutzt werden:

  • TET-Kommandozeilen-Tool
  • PLOP-/PLOP DS-Kommandozeilen-Tool